Thursday, 16 April 2009

Remote Web Workplace ActiveX add-on missing

You've just connected to your Small Business Server (SBS) via the /remote site, looking for Remote Web Workplace and get a warning at the bottom of the browser that the add-on is disabled. When you click on the add-on list the Remote Desktop (RDP) control is missing.

Ramesh over at winhelponline has the answer, you need to delete this registry key:


Then close Internet Explorer and restart. Worked a treat for a client using an IdeaPad S10e with Win XP Home and IE8.

Monday, 13 April 2009

Ignorant BT HomeHub - stops talking to laptop 2200BG wireless

Its Easter weekend - you know when geeks everywhere get to sort out their parents and neighbours home IT. Then again being a geek means any excuse to play with some kit rather than sort the garden or the spring cleaning :-)

So one of the neighbour's laptops is no longer working on wireless, turns out it hasn't been for a while. It works ok with a cabled connection. However his son-in-law is staying and his laptop doesn't work either. Escalate the call! They're running on a v1 BT HomeHub. So tried restarting the router, changing channel, varying all the security settings through none/WEP/WPA, updating the wireless driver (Intel bult-in 2200BG) - no chance. Both start connecting but report a disconnect error. One of them also gets an occasional network is no longer available error on the list. One laptop had the Windows Wireless Zero Config utility, the other used Intel Pro Wireless utility - neither would work.

Just to make it a little more interesting the other wireless devices such as Nintendo DS Lite, DSi, Playstation and my BlackBerry Bold are all perfectly happy with the wireless. After much googling I track down a bunch of guys talking about a BT HomeHub problem with Intel Centrino 2200BG wireless. Both laptops at the house are Dell Inspiron 6000 with you guessed it 2200BG wireless. Bet my IBM ThinkPad would play up too if I'd had it with me.

So the HomeHub is running firmware 6.2.6E (log into your router at and check System or Status in bottom left) which is a suspect version according to what I found. Latest version is 6.2.6H which includes a 2200BG fix according to the changelog history. Woohoo, except its not an auto update and I couldn't find a manual download to sort this firmware at the time. BT have an automated portal that should carry out a scheduled update - didn't work for us, may be a Bank Holiday issue? The link if you want to try is

I left the guys calling BT, apparently it only took a 90 minute phone call - sounds like getting off lightly with BT ;-) The initial Indian call centre had no idea about firmware, eventually got a Swedish(?) support centre that understood perfectly, checked a couple of settings and did the update. Both laptops associated straight away and were online wirelessly.

So whilst I was subsequently poking around t'interweb, I found this link
which looks like you might be able to run your own 6.2.6H update - sorry haven't had a router victim to test on yet.

Trust 1&1 Internet for your domain name registration, from only £1.99/year!. Check now!